题目描述

农夫John发现做出全威斯康辛州最甜的黄油的方法:糖。把糖放在一片牧场上,他知道N(1<=N<=500)只奶牛会过来舔它,这样就能做出能卖好价钱的超甜黄油。当然,他将付出额外的费用在奶牛上。

农夫John很狡猾。像以前的Pavlov,他知道他可以训练这些奶牛,让它们在听到铃声时去一个特定的牧场。他打算将糖放在那里然后下午发出铃声,以至他可以在晚上挤奶。

农夫John知道每只奶牛都在各自喜欢的牧场(一个牧场不一定只有一头牛)。给出各头牛在的牧场和牧场间的路线,找出使所有牛到达的路程和最短的牧场(他将把糖放在那)

输入输出格式

输入格式:

第一行: 三个数:奶牛数N,牧场数(2<=P<=800),牧场间道路数C(1<=C<=1450)

第二行到第N+1行: 1到N头奶牛所在的牧场号

第N+2行到第N+C+1行: 每行有三个数:相连的牧场A、B,两牧场间距离D(1<=D<=255),当然,连接是双向的

输出格式:

一行 输出奶牛必须行走的最小的距离和

输入输出样例

输入样例#1:

3 4 5
2
3
4
1 2 1
1 3 5
2 3 7
2 4 3
3 4 5
输出样例#1:

8

说明

{样例图形

          P2
P1 @--1--@ C1
         |
         |
       5  7  3
         |
         |     C3
       C2 @--5--@
          P3    P4

} {说明:

放在4号牧场最优

}

分析

Oops! 你的分析出现了一些问题,需要在这儿省略.

 已完成  1%                                                : (

请查阅代码:  0x8888888

 #include<iostream>
 #include<cstdio>
 #include<algorithm>
 #include<cstring>
 #include<queue>
 #include<vector>
 #include<functional>
 #define maxn 800+10
 #define inf 0x3f3f3f3f

 int n,p,c,i,j,x,y,t,ans=inf,tot,u;
 int a[maxn][maxn],w[maxn][maxn];
 *maxn];
 bool inq[maxn];
 int main() {
 fuction_init:
     {
         scanf("%d%d%d",&n,&p,&c);
         ;i<=p;i++) {
             b[i]=;
             num[i]=;
             ;j<=p;j++) w[i][j]=inf;
         }
         ;i<=n;i++)
             scanf("%d",&b[i]);
         ;i<=c;i++) {
             scanf("%d%d%d", &x, &y, &t);
             w[x][y]=w[y][x]=t;
             a[x][++num[x]]=y;
             a[y][++num[y]]=x;
         }
     }
 fuction_spfa:
     {
         ans=inf;
         ;i<=p;i++){
             ; j <= p; j++) dis[j] = inf;
             memset(team,,sizeof team);
             memset(inq,false,sizeof inq);
             dis[i]=,inq[i]=true;
             std::queue<int>q; q.push(i);
             while(!q.empty()) {
                 u=q.front();q.pop();
                 inq[u]=false;
                 ;j<=num[u];j++) {
                     int r=a[u][j];
                     if(dis[r]>dis[u]+w[u][r]) {
                         dis[r]=dis[u]+w[u][r];
                         if(!inq[r]) {
                             inq[r]=true;
                             q.push(r);
                         }
                     }
                 }
             }
             tot=;
             ;j<=n;j++) tot+=dis[b[j]];
             ans=std::min(ans,tot);
         }
         printf("%d\n",ans);
     }
 }
05-08 08:07