【推荐阅读】微服务还能火多久?>>> POJ1805 Manhattan 2025【水题】-LMLPHP

Manhattan 2025
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 2639 Accepted: 1204

Description

Background
Manhattan in the year 2025 - it is so densely populated that its old two-dimensional grid of streets and avenues fails to provide enough space for all the traditional vehicles such as cars, bicycles, or busses.Accordingly, the newly developed 3D-Skyjetters become very popular, because they allow to pass the traffic jams on the ground by flying in the air. After a series of horrible accidents caused by 3D-Skyjetters cutting a corner, New York authorities have put into place new regulations of air traffic and are determined to enforce them rigorously. The key point of these regulations is that 3D-Skyjetters must follow virtual airways on a three-dimensional rectangular grid, easy enough for the New Yorkers who had to use the two-dimensional rectangular grid of roads on the ground all their life.
Problem
You own a company that rents out 3D-Skyjetters. As 3D-Skyjetters are in such an early state of development,they are far from being economical. So your customers keep running out of petrol at all the wrong places,and you need a system to inform them about their current range at all times.
You may assume that travelling from one intersection to the next in the grid takes one unit of petrol, no matter if the customer is moving horizontally or vertically, up or down. You may also assume that your customer is located at some intersection where his or her movements are not restricted by the ground or other obstacles, but just by the amount of remaining petrol.
Given the amount of petrol, provide a graphical representation of all the intersections in the range of your customer, along with the amount of petrol that is needed to go there.




Input

The first line of the input contains the number of scenarios. For each scenario, there is a line containing the units of remaining petrol, i.e an integer u satisfying 0 <= u <= 9. If more than 9 units of petrol remain, the customer will ignore the display anyway.

Output

Start the output for each scenario with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a graphical (or rather textual) representation of all intersections that can be reached with the given amount of petrol, along with the units of petrol necessary to go there. In this graphical representation, print the slices of the smallest axis-aligned three-dimensional cube containing all the intersections in the range, and label the slices from the bottom to the top starting at 1. For each slice,start the output with a line containing “slice #s:”, where s is the number of the slice. In the lines that follow, print a graphical representation of all the intersections in that slice, using
the digits 0 to 9 for intersections in the range, representing the amount of petrol necessary to go there,
and the dot “.” for intersections not in the range.

Print an additional blank line after each scenario.

Sample Input

2
0
2

Sample Output

Scenario #1:
slice #1:
0

Scenario #2:
slice #1:


…2…


slice #2:

…2…
.212.
…2…

slice #3:
…2…
.212.
21012
.212.
…2…
slice #4:

…2…
.212.
…2…

slice #5:


…2…































Source

TUD Programming Contest 2003, Darmstadt, Germany

问题链接POJ1805 Manhattan 2025
问题简述:(略)
问题分析:题目太长,不解释看代码。
程序说明:(略)
参考链接:(略)
题记:(略)




AC的C++语言程序如下:

/* POJ1805 Manhattan 2025 */

#include <iostream>
#include <cstdio>
#include <cstdlib>

using namespace std;

void gprint(int u)
{
    for(int k = 1; k <= 2 * u + 1; k++) {
        printf("slice #%d:\n", k);
        for(int i = 1; i <= 2 * u + 1; i++) {
            for(int j = 1; j <= 2 * u + 1; j++) {
                int u2 = abs(u +1 - i) + abs(u + 1 - j) + abs(u +1 - k);     // 计算走到相应位置需要的油量
                if(u2 > u) printf(".");
                else printf("%d", u2);
            }
            printf("\n");
        }
    }
}

int main()
{
    int t, u;
    scanf("%d", &t);
    for(int k = 1; k <= t; k++) {
        scanf("%d", &u);
        if(u >= 0 && u <= 9) {
            printf("Scenario #%d:\n", k);
            gprint(u);
        }
        printf("\n");
    }

    return 0;
}
发布了2269 篇原创文章 · 获赞 2374 · 访问量 264万+
04-15 18:30