Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2026    Accepted Submission(s):
1428

Problem Description
Tang and Jiang are good friends. To decide whose treat
it is for dinner, they are playing a game. Specifically, Tang and Jiang will
alternatively write numbers (integers) on a white board. Tang writes first, then
Jiang, then again Tang, etc... Moreover, assuming that the number written in the
previous round is X, the next person who plays should write a number Y such that
1 <= Y - X <= k. The person who writes a number no smaller than N first
will lose the game. Note that in the first round, Tang can write a number only
within range [1, k] (both inclusive). You can assume that Tang and Jiang will
always be playing optimally, as they are both very smart students.
 
Input
There are multiple test cases. For each test case,
there will be one line of input having two integers N (0 < N <= 10^8) and
k (0 < k <= 100). Input terminates when both N and k are zero.
 
Output
For each case, print the winner's name in a single
line.
 
Sample Input
1 1
30 3
10 2
0 0
 
Sample Output
Jiang
Tang
Jiang
 
Source
 
Recommend
liuyiding   |   We have carefully selected several
similar problems for you:  6263 6262 6261 6260 6259 
 
 
我们可以把模型抽象一下
有$n-1$个石子,一个人最多拿$k$个,问最后谁赢
——》裸的巴什博奕
 
 
#include<cstdio>
#include<algorithm>
using namespace std;
const int MAXN=1e6+,INF=1e9+;
int main()
{
#ifdef WIN32
freopen("a.in","r",stdin);
#else
#endif
int x,y;
while(scanf("%d%d",&x,&y))
{
if(x==&&y==) break;
if( (x-)%(y+)== ) printf("Jiang\n");
else printf("Tang\n");
}
return ;
}
05-08 15:50