https://pintia.cn/problem-sets/994805046380707840/problems/994805061769609216
呵呵。大家都知道五服以内不得通婚,即两个人最近的共同祖先如果在五代以内(即本人、父母、祖父母、曾祖父母、高祖父母)则不可通婚。本题就请你帮助一对有情人判断一下,他们究竟是否可以成婚?
输入格式:
输入第一行给出一个正整数N
(2 ≤ N
≤),随后N
行,每行按以下格式给出一个人的信息:
本人ID 性别 父亲ID 母亲ID
其中ID
是5位数字,每人不同;性别M
代表男性、F
代表女性。如果某人的父亲或母亲已经不可考,则相应的ID
位置上标记为-1
。
接下来给出一个正整数K
,随后K
行,每行给出一对有情人的ID
,其间以空格分隔。
注意:题目保证两个人是同辈,每人只有一个性别,并且血缘关系网中没有乱伦或隔辈成婚的情况。
输出格式:
对每一对有情人,判断他们的关系是否可以通婚:如果两人是同性,输出Never Mind
;如果是异性并且关系出了五服,输出Yes
;如果异性关系未出五服,输出No
。
输入样例:
24
00001 M 01111 -1
00002 F 02222 03333
00003 M 02222 03333
00004 F 04444 03333
00005 M 04444 05555
00006 F 04444 05555
00007 F 06666 07777
00008 M 06666 07777
00009 M 00001 00002
00010 M 00003 00006
00011 F 00005 00007
00012 F 00008 08888
00013 F 00009 00011
00014 M 00010 09999
00015 M 00010 09999
00016 M 10000 00012
00017 F -1 00012
00018 F 11000 00013
00019 F 11100 00018
00020 F 00015 11110
00021 M 11100 00020
00022 M 00016 -1
00023 M 10012 00017
00024 M 00022 10013
9
00021 00024
00019 00024
00011 00012
00022 00018
00001 00004
00013 00016
00017 00015
00019 00021
00010 00011
输出样例:
Never Mind
Yes
Never Mind
No
Yes
No
Yes
No
No
代码:
#include <bits/stdc++.h>
using namespace std; const int maxn = 1e5 + 10;
int N, Q;
int prefa[maxn], premot[maxn];
int sex[maxn]; void init() {
memset(prefa, -1, sizeof(prefa));
memset(premot, -1, sizeof(premot));
} bool CanMerry(int x, int y, int step) {
if(x == -1 && y == -1) return true;
if((prefa[x] != -1 && prefa[x] == prefa[y]) || (premot[x] != -1 && premot[x] == premot[y]))
return false; step ++;
if(step >= 4) return true; return CanMerry(premot[x], premot[y], step) &&
CanMerry(prefa[x], prefa[y], step) &&
CanMerry(prefa[x], premot[y], step) &&
CanMerry(premot[x], prefa[y], step);
} int main() {
scanf("%d", &N);
init();
for(int i = 0; i < N; i ++) {
int child, fa, mot;
string s;
scanf("%d", &child);
cin >> s;
scanf("%d%d", &fa, &mot);
if(s == "M") sex[child] = 1;
else if(s == "F") sex[child] = 0; prefa[child] = fa;
premot[child] = mot; if(fa != -1) sex[fa] = 1;
if(mot != -1) sex[mot] = 0;;
} scanf("%d", &Q);
while(Q --) {
int a, b;
scanf("%d%d", &a, &b);
if(sex[a] == sex[b]) printf("Never Mind\n");
else {
if(CanMerry(a, b, 0)) printf("Yes\n");
else printf("No\n");
}
} return 0;
}
递归 700 篇啦!撒花撒花