RXD and math

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 568    Accepted Submission(s): 306

Problem Description
RXD is a good mathematician.
One day he wants to calculate:

∑i=1nkμ2(i)×⌊nki−−−√⌋

output the answer module 109+7.
1≤n,k≤1018

μ(n)=1(n=1)
μ(n)=(−1)k(n=p1p2…pk)
μ(n)=0(otherwise)

p1,p2,p3…pk are different prime numbers

Input
There are several test cases, please keep reading until EOF.
There are exact 10000 cases.
For each test case, there are 2 numbers n,k.
 
Output
For each test case, output "Case #x: y", which means the test case number and the answer.
Sample Input
10 10
 
Sample Output
Case #1: 999999937
Source
 
Recommend
liuyiding   |   We have carefully selected several similar problems for you:  6066 6065 6064 6063 6062 

题解:n^k % mod

注意 :n因为非常大所以在开始就要先用 mod 运算一遍

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<map>
#include<vector>
using namespace std;
const long long m=1e9+;
long long n,k;
long long solve(long long a,long long b)
{
a=a%m;
long long ans=;
while(b)
{
if (b&)ans=(ans*a)%m;
b>>=;
a=(a*a)%m;
}
return ans;
}
int main()
{
int cas=;
while(scanf("%lld%lld",&n,&k)!=EOF)
{
printf("Case #%d: %lld\n",++cas,solve(n,k));
}
return ;
}
05-11 21:52