时间限制:5 秒

内存限制:32 兆

特殊判题:否

提交:4574

解决:1318

题目描述:
    哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。



    给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”
输入:

首先列出词典中不超过100000条不同的魔咒词条,每条格式为:



    [魔咒] 对应功能



    其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。

    词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

输出:
    每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”
样例输入:
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky
样例输出:
light the wand
accio
what?
what?
来源:
2008年浙江大学计算机及软件工程研究生机试真题

思路:

使用结构体建立字典数组,分别采取定义两种cmp函数(各以魔咒和功能为排序关键字),分别排序生成两种字典。

查找时分别用两种字典即可。

代码:

#include <stdio.h>
#include <stdlib.h>
#include <string.h> #define N 100010 typedef struct node {
char name[30];
char func[90];
} DICT; DICT d[N], d1[N];
int n; int cmp(const void *a, const void *b)
{
DICT *x = (DICT *)a;
DICT *y = (DICT *)b;
return strcmp(x->name, y->name);
} int cmp1(const void *a, const void *b)
{
DICT *x = (DICT *)a;
DICT *y = (DICT *)b;
return strcmp(x->func, y->func);
} int main(void)
{
int i, k;
char s[110]; while (gets(s) != NULL)
{
n = 0;
while (s[0] == '[')
{
i = 1;
while (s[i] != ']')
{
d[n].name[i-1] = s[i];
i++;
}
d[n].name[i-1] = '\0';
strcpy(d1[n].name, d[n].name);
strcpy(d[n].func, s+i+2);
strcpy(d1[n].func, s+i+2);
n ++;
gets(s);
} qsort(d, n, sizeof(d[0]), cmp);
qsort(d1, n, sizeof(d1[0]), cmp1); scanf("%d", &k);
getchar();
while (k--)
{
gets(s);
if (s[0] == '[')
{
i = 1;
while (s[i] != ']')
{
s[i-1] = s[i];
i++;
}
s[i-1] = '\0';
}
DICT dict;
strcpy(dict.name, s);
strcpy(dict.func, s);
DICT *p = (DICT *)bsearch(&dict, d, n, sizeof(d[0]), cmp);
if (p != NULL)
{
printf("%s\n", p->func);
continue;
}
p = (DICT *)bsearch(&dict, d1, n, sizeof(d1[0]), cmp1);
if (p != NULL)
{
printf("%s\n", p->name);
continue;
}
printf("what?\n");
}
break;
} return 0;
}
/**************************************************************
Problem: 1029
User: liangrx06
Language: C
Result: Accepted
Time:10 ms
Memory:24356 kb
****************************************************************/

05-11 17:56