Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
 
Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
 
Output
请输出按照要求改写后的英文句子。
 
Sample Input
i like acm
i want to get an accepted
 
Sample Output
I Like Acm
I Want To Get An Accepted
    
          看见这个题目我想起流处理,更加方便,另外,还要注意输出格式。
 #include<bits/stdc++.h>
#define LL long long
using namespace std;
int main()
{
char c[];
while(gets(c))//读取一行
{
stringstream ss(c);//复制
string s;bool r=true;
while(ss>>s)//从ss读入s中
{
s[]=toupper(s[]);//将小写变为大写
if(r==true) {r=;cout<<s;}
else cout<<" "<<s;
}
cout<<endl;
}
}
05-11 13:17