1011 A+B和C (15)(15 分)

给定区间[-2^31^, 2^31^]内的3个整数A、B和C,请判断A+B是否大于C。

输入格式:

输入第1行给出正整数T(<=10),是测试用例的个数。随后给出T组测试用例,每组占一行,顺序给出A、B和C。整数间以空格分隔。

输出格式:

对每组测试用例,在一行中输出“Case #X: true”如果A+B>C,否则输出“Case #X: false”,其中X是测试用例的编号(从1开始)。

输入样例:

4
1 2 3
2 3 4
2147483647 0 2147483646
0 -2147483648 -2147483647

输出样例:

Case #1: false
Case #2: true
Case #3: true
Case #4: false

注意:数据用long long(测试点2、3答案错误)

C++: 

#include<iostream>
using namespace std;
int main() {
int n;
long long a, b, c; //注意数据范围
cin >> n;
int k = 1;
while (n--) {
cin >> a >> b >> c;
switch (a + b > c){
case 1:
cout << "Case #" << k++ << ": true"<<endl;
break;
case 0:
cout << "Case #" << k++ << ": false"<<endl;
break;
}
}
return 0;
}

JAVA:

import java.util.Scanner;
public class Main{
public static boolean judge(long A,long B,long C){
return A+B>C;
}
public static void main(String [] args){
Scanner input=new Scanner(System.in);
long A,B,C;
int n=input.nextInt();
for(int i=1;i<=n;i++){
A=input.nextLong();
B=input.nextLong();
C=input.nextLong();
System.out.print("Case #"+i+": ");
if(judge(A,B,C))
System.out.println("true");
else
System.out.println("false");
}
}
}

Python:

if __name__=="__main__":
n=int(input())
for i in range(0,n):
a,b,c=map(int,input().split())
print("Case #%d: " % (i+1),end="")
if a+b>c:
print("true")
else:
print("false")
04-30 10:40