一个很坑的问题,想到点子上很好解决,想不到的话头破也不一定能做出来。

There is a hill with n holes around. The holes are signed from 0 to n-1.

hdu1222Wolf and Rabbit (公约数的巧题)-LMLPHP

A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

Input The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
Output For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
Sample Input
2
1 2
2 2

Sample Output

NO
YES

直接上解题思路:如果m和n的最大公约数是1,那么总有狼到不了的地方,所以问题的关键就是最大公约数,欧几里得就搞定了。

下面是代码:

#include<cstdio>
int gcd(int x,int y){
return !y?x:gcd(y,x%y);
}
int main()
{
int p,m,n;
scanf("%d",&p);
while(p--){
scanf("%d%d",&m,&n);
if(gcd(m,n)==1) printf("NO\n");
else printf("YES\n");
}
}

这样就很轻松就解决了。

05-21 10:08