营业额统计

营业额统计 Tiger最近被公司升任为营业部经理,他上任后接受公司交给的第一项任务便是统计并分析公司成立以来的营业情况。 Tiger拿出了公司的账本,账本上记录了公司成立以来每天的营业额。分析营业情况是一项相当复杂的工作。由于节假日,大减价或者是其他情况的时候,营业额会出现一定的波动,当然一定的波动是能够接受的,但是在某些时候营业额突变得很高或是很低,这就证明公司此时的经营状况出现了问题。经济管理学上定义了一种最小波动值来衡量这种情况: 该天的最小波动值 当最小波动值越大时,就说明营业情况越不稳定。 而分析整个公司的从成立到现在营业情况是否稳定,只需要把每一天的最小波动值加起来就可以了。你的任务就是编写一个程序帮助Tiger来计算这一个值。 第一天的最小波动值为第一天的营业额。

Input

第一行为正整数 ,表示该公司从成立一直到现在的天数,接下来的n行每行有一个整数(有可能有负数) ,表示第i天公司的营业额。

Output

输出文件仅有一个正整数,即Sigma(每天最小的波动值) 。结果小于2^31 。

Sample Input

	6
5
1
2
5
4
6

Sample Output

	12
此模板里的查前驱后继是正确的。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <time.h>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#define maxn 102
using namespace std;
const int inf=0x3f3f3f3f;
const int MAXN=2e5+;
int lim;
struct SplayTree {
int sz[MAXN];
int ch[MAXN][];
int pre[MAXN];
int rt,top;
inline void up(int x) {
sz[x] = cnt[x] + sz[ ch[x][] ] + sz[ ch[x][] ];
}
inline void Rotate(int x,int f) {
int y=pre[x];
ch[y][!f] = ch[x][f];
pre[ ch[x][f] ] = y;
pre[x] = pre[y];
if(pre[x]) ch[ pre[y] ][ ch[pre[y]][] == y ] =x;
ch[x][f] = y;
pre[y] = x;
up(y);
}
inline void Splay(int x,int goal) { //将x旋转到goal的下面
while(pre[x] != goal) {
if(pre[pre[x]] == goal) Rotate(x, ch[pre[x]][] == x);
else {
int y=pre[x],z=pre[y];
int f = (ch[z][]==y);
if(ch[y][f] == x) Rotate(x,!f),Rotate(x,f);
else Rotate(y,f),Rotate(x,f);
}
}
up(x);
if(goal==) rt=x;
}
inline void RTO(int k,int goal) { //将第k位数旋转到goal的下面
int x=rt;
while(sz[ ch[x][] ] != k-) {
if(k < sz[ ch[x][] ]+) x=ch[x][];
else {
k-=(sz[ ch[x][] ]+);
x = ch[x][];
}
}
Splay(x,goal);
}
inline void vist(int x) {
if(x) {
printf("结点%2d : 左儿子 %2d 右儿子 %2d %2d sz=%d\n",x,ch[x][],ch[x][],val[x],sz[x]);
vist(ch[x][]);
vist(ch[x][]);
}
}
inline void Newnode(int &x,int c) {
x=++top;
ch[x][] = ch[x][] = pre[x] = ;
sz[x]=;
cnt[x]=;
val[x] = c;
}
inline void init() {
sum=ch[][]=ch[][]=pre[]=sz[]=;
rt=top=;
cnt[]=;
Newnode(rt,-inf);
Newnode(ch[rt][],inf);
pre[top]=rt;
sz[rt]=;
}
inline void Insert(int &x,int key,int f) {
if(!x) {
Newnode(x,key);
pre[x]=f;
Splay(x,);
return ;
}
if(key==val[x]) {
cnt[x]++;
sz[x]++;
Splay(x,);
return ;
} else if(key<val[x]) {
Insert(ch[x][],key,x);
} else {
Insert(ch[x][],key,x);
}
up(x);
}
//找前驱
void findpre(int x,int key,int &ans){
if(!x) return ;
if(val[x] <= key){
ans=val[x];
findpre(ch[x][],key,ans);
} else
findpre(ch[x][],key,ans);
}
void findsucc(int x,int key,int &ans){
if(!x) return ;
if(val[x]>=key) {
ans=val[x];
findsucc(ch[x][],key,ans);
} else
findsucc(ch[x][],key,ans);
}
void del(int &x,int f) {
if(!x) return ;
if(val[x]>=lim) {
del(ch[x][],x);
} else {
sum+=sz[ch[x][]]+cnt[x];
x=ch[x][];
pre[x]=f;
if(f==) rt=x;
del(x,f);
}
if(x) up(x);
}
inline void update() {
del(rt,);
}
inline int find_kth(int x,int k) {
if(k<sz[ch[x][]]+) {
return find_kth(ch[x][],k);
} else if(k > sz[ ch[x][] ] + cnt[x] )
return find_kth(ch[x][],k-sz[ch[x][]]-cnt[x]);
else {
Splay(x,);
return val[x];
}
}
int cnt[MAXN];
int val[MAXN];
int sum;
} spt;
int main() {
int n;
scanf("%d",&n);
spt.init();
int ans=,a;
scanf("%d",&a);
spt.Insert(spt.rt,a,);
ans=a;
n--;
while(n--){
a=;
scanf("%d",&a);
int x,y;
spt.findpre(spt.rt,a,x);
spt.findsucc(spt.rt,a,y);
ans+=min(abs(a-x),abs(a-y));
spt.Insert(spt.rt,a,);
}
printf("%d\n",ans);
return ;
}
05-11 13:03