1078 Hashing (25 分)
The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.
Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.
Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤104) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.
Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 -
题目大意:
给出m为表大小以及n个数,要求输出在散列表中的位置。散列方法如下:H(key) = key % m;并采用正二次方探测法解决冲突。
思路:
核心在于二次方探测法中一定是 p = (key + step * step) % m。
判别是否为素数,模板算法。
参考代码:
#include<vector>
#include<cstdio>
using namespace std;
vector<int> exist;
bool isprime(int v){
if(v == 1) return false;
for(int i = 2; i * i <= v; ++i)
if(v % i == 0) return false;
return true;
}
int main(){
int m, n;
scanf("%d%d", &m, &n);
while(!isprime(m)) m++;
exist.resize(m);
for(int i = 0; i < n; ++i){
int temp, p, step = 1;
scanf("%d", &temp);
p = temp % m;
if(exist[p]){
while(exist[p] && step < m) p = (temp + step * step) % m, step++;
if(!exist[p]){
printf("%d%c", p, i != n - 1? ' ': '\n');
exist[p] = true;
}else printf("-%c", i != n - 1?' ': '\n');
}else{
printf("%d%c", p, i != n - 1? ' ': '\n');
exist[p] = true;
}
}
return 0;
}