1081 Rational Sum (20 分)
Given N rational numbers in the form numerator/denominator
, you are supposed to calculate their sum.
Input Specification:
Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 ...
where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.
Output Specification:
For each test case, output the sum in the simplest form integer numerator/denominator
where integer
is the integer part of the sum, numerator
< denominator
, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.
Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:
7/24
题目大意:
给定n个的分数,要求分数的和,并以带分数的形式输出。
思路:
由于标明分子分母都是长整型,那么就有可能是全为最大的长整型数。那么最好还是用string存储,并进行处理。
参考代码:
#include<cstdio>
#include<cstdlib>
long long num, denum, integer, gcdv;
long long gcd(long long a, long long b){return b == 0? abs(a): gcd(b, a % b);}
int main(){
int n;
scanf("%d", &n);
for(int i = 0; i < n; ++i){
long long t1, t2;
scanf("%lld/%lld", &t1, &t2);
gcdv = gcd(t1, t2);
t1 /= gcdv, t2 /= gcdv;
if(i == 0){
num = t1, denum = t2;
continue;
}
num = t1 * denum + num * t2;
denum = t2 * denum;
gcdv = gcd(num, denum);
num /= gcdv, denum /= gcdv;
}
integer = num / denum;
num = num - (denum * integer);
if(integer != 0){
printf("%lld", integer);
if(num != 0) printf(" ");
}
if(num != 0) printf("%lld/%lld", num, denum);
if(integer == 0 && num ==0) printf("0");
return 0;
}