题目描述 Description

给出一棵二叉树的中序与后序排列。求出它的先序排列。(约定树结点用不同的大写字母表示,长度<=8)。

输入描述 Input Description

两个字符串,分别是中序和后序(每行一个)

输出描述 Output Description

一个字符串,先序

样例输入 Sample Input

BADC

BDCA

样例输出 Sample Output

ABCD

分类标签 Tags 点此展开

pre:先序排列,后序排列,中序排列是什么

    了解pre直通车

#include<cstdio>
#include<iostream>
#include<string>
#include<cstring>
using namespace std; string z,h;//最长为8 void xx(int l1,int r1,int l2,int r2)
{
cout<<h[r2];
int m=z.find(h[r2]);
if(m>l1) xx(l1,m-,l2,l2+m-l1-);
if(m<r1) xx(m+,r1,l2+m-l1,r2-);
} int main()
{
cin>>z>>h;
xx(,z.length()-,,h.length()-);
return ;
}
05-11 20:54