GTY's math problem
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2099 Accepted Submission(s): 774
Problem Description
GTY
is a GodBull who will get an Au in NOI . To have more time to learn
algorithm knowledge, he never does his math homework. His math teacher
is very unhappy for that, but she can't do anything because GTY can
always get a good mark in math exams. One day, the math teacher asked
GTY to answer a question. There are four numbers on the blackboard - a,b,c,d. The math teacher wants GTY to compare ab with cd.
Because GTY never does his homework, he can't figure out this problem!
If GTY can't answer this question correctly, he will have to do his
homework. So help him!
is a GodBull who will get an Au in NOI . To have more time to learn
algorithm knowledge, he never does his math homework. His math teacher
is very unhappy for that, but she can't do anything because GTY can
always get a good mark in math exams. One day, the math teacher asked
GTY to answer a question. There are four numbers on the blackboard - a,b,c,d. The math teacher wants GTY to compare ab with cd.
Because GTY never does his homework, he can't figure out this problem!
If GTY can't answer this question correctly, he will have to do his
homework. So help him!
Input
Multi test cases (about 5000). Every case contains four integers a,b,c,d(1≤a,b,c,d≤1000)separated by spaces. Please process to the end of file.
Output
For each case , if ab>cd , print '>'. if ab<cd , print '<'. if ab=cd , print '='.
Sample Input
2 1 1 2
2 4 4 2
10 10 9 11
2 4 4 2
10 10 9 11
Sample Output
>
=
<
=
<
题意:判断 a^b 和 c^d 的大小关系.
题解:同时平方肯定会炸,所以取对数之后进行比较.
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#include <math.h>
using namespace std;
const double eps = 1e-; int main()
{
int a,b,c,d;
while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF){
double n = b*log(a)-d*log(c);
if(fabs(n)<eps) printf("=\n");
else if(n<) printf("<\n");
else printf(">\n");
}
return ;
}