101-两点距离

内存限制:64MB
时间限制:3000ms
特判: No

通过数:27
提交数:74
难度:1

题目描述:

输入两点坐标(X1,Y1),(X2,Y2)(0<=x1,x2,y1,y2<=1000),计算并输出两点间的距离。

输入描述:

第一行输入一个整数n(0<n<=1000),表示有n组测试数据;
随后每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。

输出描述:

对于每组输入数据,输出一行,结果保留两位小数。误差在0.01 范围内就可以通过。

样例输入:

复制

2
0 0 0 1
0 1 1 0

样例输出:

1.00
1.41

C/C++ AC:

 #include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <stack>
#include <set>
#include <map>
#include <queue>
#include <climits> using namespace std;
int N; int main()
{
cin >> N;
while (N --)
{
double X1, X2, Y1,Y2;
cin >> X1 >>Y1 >>X2 >>Y2; printf("%.2f\n", sqrt((X1 - X2)*(X1 - X2) + (Y1 - Y2)*(Y1 - Y2)));
}
}
05-22 15:19