Problem 2230 翻翻棋

Accept: 872    Submit: 2132
Time Limit: 1000 mSec    Memory Limit : 32768 KB

FZU  OJ:2230 翻翻棋-LMLPHP Problem Description

象棋翻翻棋(暗棋)中双方在4*8的格子中交战,有时候最后会只剩下帅和将。根据暗棋的规则,棋子只能上下左右移动,且相同的级别下,主动移动到地方棋子方将吃掉对方的棋子。将和帅为同一级别。然而胜负在只剩下帅和将的时候已定。

FZU  OJ:2230 翻翻棋-LMLPHP Input

第一行T,表示T组数据。

每组数据共有四行字符串,每行字符串共八个字符

’#’表示空格

’*’表示红方帅

’.’表示黑方将

此时红方先走

每组输入之间没有空行。

FZU  OJ:2230 翻翻棋-LMLPHP Output

每组数据输出一行。若为红方赢输出Red win,否则输出 Black win

FZU  OJ:2230 翻翻棋-LMLPHP Sample Input

1
######.#
#####*##
########
########

FZU  OJ:2230 翻翻棋-LMLPHP Sample Output

Black win

找规律就可以了,自己在纸上多画几次,

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#define ll long long
using namespace std;
const int maxn=1e6+10;
char a[20][20];
int main()
{
int t;
cin>>t;
while(t--)
{
int red_x,red_y,black_x,black_y;
for(int i=0;i<4;i++)
for(int j=0;j<8;j++)
cin>>a[i][j];
for(int i=0;i<4;i++)
for(int j=0;j<8;j++)
{
if(a[i][j]=='*')
{
red_x=j;
red_y=i;
}
if(a[i][j]=='.')
{
black_x=j;
black_y=i;
}
}
if((abs(red_x-black_x)+abs(red_y-black_y))%2==0) cout<<"Black win\n";
else cout<<"Red win\n";
}
return 0;
}
05-11 19:31