编程团体赛的规则为:每个参赛队由若干队员组成;所有队员独立比赛;参赛队的成绩为所有队员的成绩和;成绩最高的队获胜。

现给定所有队员的比赛成绩,请你编写程序找出冠军队。

输入格式:

输入第一行给出一个正整数N(<=10000),即所有参赛队员总数。随后N行,每行给出一位队员的成绩,格式为:“队伍编号-队员编号 成绩”,其中“队伍编号”为1到1000的正整数,“队员编号”为1到10的正整数,“成绩”为0到100的整数。

输出格式:

在一行中输出冠军队的编号和总成绩,其间以一个空格分隔。注意:题目保证冠军队是唯一的。

输入样例:

6
3-10 99
11-5 87
102-1 0
102-3 100
11-9 89
3-2 61

输出样例:

11 176

下面两种方法都超时!!!
 package com.hone.basical;

 import java.util.Scanner;
/**
* 方法1
* 原题目:https://www.patest.cn/contests/pat-b-practise/1047
* @author Xia
* 下面利用简单一点的方法解决,在读取数据的同时将数据分了,将学校相同的学生的成绩加起来
* 时间复杂度为n
* 根据ID定位数据,建立以id为下标的数组
* 类似于:挖掘机技术哪家强
*/
public class basicalLevel1047programTeamGame { public static void main(String[] args) {
Scanner in = new Scanner(System.in);
int n = in.nextInt();
int[] score = new int[1000];
int a;
int maxId = 0; //标记得分最高的队伍
for (int i = 0; i < n; i++) {
String str = in.nextLine();
String[] strNum = str.split("\\-|\\s");
a = Integer.parseInt(strNum[0]);
score[a] += Integer.parseInt(strNum[2]); //将a作为score数组的下标
if (score[a] > score[maxId]) {
maxId = a;
}
}
System.out.println(maxId+" "+score[maxId]);
}
}
 package com.hone.basical;

 import java.util.Scanner;
/**
* 这种方法较为麻烦,还是推荐第一种的用teamNum做下标
* 原题目:https://www.patest.cn/contests/pat-b-practise/1047
* @author Xia
*/
public class basicalLevel1047programTeamGame2 { public static void main(String[] args) {
Scanner in = new Scanner(System.in);
int n = Integer.parseInt(in.nextLine());
int[] teamNum = new int[n];
int[] personNum = new int[n];
int[] score = new int[n];
int[] sum = new int[n];
int sumMax = 0;
int k = 0;
for (int i = 0; i < n; i++) {
String str = in.nextLine();
String[] strNum = str.split("\\-|\\s");
teamNum[i] = Integer.parseInt(strNum[0]);
personNum[i] = Integer.parseInt(strNum[1]);
score[i] = Integer.parseInt(strNum[2]);
}
for (int i = 0; i < n; i++) {
for (int j = 0; j < n; j++) {
if (teamNum[i]==teamNum[j]) {
sum[i]+=score[j];
}
}
if (sumMax<sum[i]) {
sumMax = sum[i];
k = i;
}
}
System.out.println(teamNum[k]+" "+sumMax);
}
}
05-11 09:39