Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

C++:

#include<iostream>
using namespace std;
typedef long long LL;
LL gcd(LL a,LL b)
{
    return b?gcd(b,a%b):a;
}

int main()
{
    LL a=0,b=1;
    int n;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        LL c,d;
        scanf("%lld/%lld",&c,&d);
        LL t=gcd(c,d);
        c/=t,d/=t;
        t=gcd(b,d);
        a=d/t*a+b/t*c;
        b=b/t*d;
        t=gcd(a,b);
        a/=t,b/=t;
    }
    if(b==1)  cout<<a;
    else
    {
        if(a>=b)  printf("%lld ",a/b),a%=b;
        printf("%lld/%lld",a,b);
    }
    return 0;
}
11-23 13:58