Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!
Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.
Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.
Output Specification:
For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.
Sample Input:
1234567899
Sample Output:
Yes
2469135798
C++:
#include <bits/stdc++.h>
using namespace std;
int main()
{
string A;
vector<int> a;
cin>>A;
for(int i=A.size()-1;i>=0;i--)
{
a.push_back(A[i]-'0');
}
vector<int> b;
int t=0;
for(int i=0;i<a.size();i++)
{
int s=a[i]+a[i]+t;
b.push_back(s%10);
t=s/10;
}
if(t)
{
b.push_back(t);
}
vector<int> c=b;
sort(a.begin(),a.end());
sort(b.begin(),b.end());
if(a==b)
{
printf("Yes\n");
}
else
{
printf("No\n");
}
for(int i=c.size()-1;i>=0;i--)
{
printf("%d",c[i]);
}
return 0;
}