A/B

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7310    Accepted Submission(s):
5798

Problem Description
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973)
= 1)。
 
Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n <
9973)和B(1 <= B <= 10^9)。
 
Output
对应每组数据输出(A/B)%9973。
 
Sample Input
2
1000 53
87 123456789
 
Sample Output
7922
6060
 
Author
xhd
 
Source
 
Recommend
linle   |   We have carefully selected several similar
problems for you:  1788 1211 1787 1299 1573 

解题思路:

(1)n=A%9973,则n=A-A/9973*9973。又A/B=x,则A=Bx。所以Bx-A/9973*9973=n。即Bx-9973y=n。

到这里我们可以发现:只要求出x的值,即可算出x%9973,也就是(A/B)%9973了。顺利解决了!            gcd(a,b) = ax + by;

(2)如何求出x呢?题目的输入是n和B,利用扩展欧几里德算法可求出gcd(B,9973)=Bx1+9973y1=1的x1,y1。

等式两边同乘以n,得B(nx1)-9973(-ny1)=n(nx1=x.-ny1=y).可知nx1就是Bx-9973y=n的解了!!!即x=nx1。

(3)对于(2)得到的x可能是负数,由题这显然是不正确的,如果是负数则加上9973再与n相乘后%9973即可得到正确结果。

 #include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <string>
#include <queue>
#include <stack>
#include <algorithm> #define INF 0x7fffffff
#define EPS 1e-12
#define MOD 1000000007
#define PI 3.141592653579798
#define N 100000 using namespace std; typedef long long LL; LL e_gcd(LL a, LL b, LL &x, LL &y)
{
LL d = a;
if (b != )
{
d = e_gcd(b, a%b, y, x);
y -= a / b * x;
}
else
{
x = ; y = ;
}
return d;
} LL cal(LL a, LL b, LL c)
{
LL x, y;
LL gcd = e_gcd(a, b, x, y);
if (c%gcd != ) return -;
x *= c / gcd;
b /= gcd;
if (b < ) b = -b;
LL ans = x % b;
if (ans <= ) ans += b;
return ans;
} int main()
{
LL n, b, t;
cin >> t;
while (t--)
{
scanf("%I64d%I64d", &n, &b);
LL ans = cal(b, , n);
if (ans == -) printf("Impossible\n");
else printf("%lld\n", ans);
}
return ;
}
05-11 18:34