顺序表应用6:有序顺序表查询
Time Limit: 1000 ms Memory Limit: 4096 KiB
Problem Description
顺序表内按照由小到大的次序存放着n个互不相同的整数,任意输入一个整数,判断该整数在顺序表中是否存在。如果在顺序表中存在该整数,输出其在表中的序号;否则输出“No Found!"。
Input
第一行输入整数n (1 <= n <= 100000),表示顺序表的元素个数;
第二行依次输入n个各不相同的有序非负整数,代表表里的元素;
第三行输入整数t (1 <= t <= 100000),代表要查询的次数;
第四行依次输入t个非负整数,代表每次要查询的数值。
保证所有输入的数都在 int 范围内。
Output
输出t行,代表t次查询的结果,如果找到在本行输出该元素在表中的位置,否则本行输出No Found!
Sample Input
10
1 22 33 55 63 70 74 79 80 87
4
55 10 2 87
Sample Output
4
No Found!
No Found!
10
数据量大用二分;;
#include <stdio.h>
#include <stdlib.h>
int List[100010];
int i, j, k;
int search(int a[], int lt, int rt, int x)
{
while(lt <= rt)
{
int mid = (rt + lt) / 2;
if(a[mid] == x)
return mid+1;
else if(a[mid] < x)
{
lt = mid + 1;
}
else if(a[mid] > x)
{
rt = mid-1;
}
}
return 0;
}
int main()
{
int n, t, x;
scanf("%d", &n);
for(i=0; i<n; i++)
{
scanf("%d", &List[i]);
}
scanf("%d", &t);
while(t--)
{
scanf("%d", &x);
k = search( List, 0, n-1, x);
if(k)
printf("%d\n", k);
else
printf("No Found!\n");
}
return 0;
}