最少乘法次数
时间限制:1000 ms | 内存限制:65535 KB
难度:3
- 描述
给你一个非零整数,让你求这个数的n次方,每次相乘的结果可以在后面使用,求至少需要多少次乘。如2:2*2=2(第一次乘),2*2=2(第二次乘),所以最少共2次;
- 输入
- 第一行m表示有m(1<=m<=100)组测试数据;
每一组测试数据有一整数n(0<n<=10000); - 输出
- 输出每组测试数据所需次数s;
- 样例输入
3
2
3
4- 样例输出
1
2
2- 上传者
- 李剑锋
- 解题:快速幂。。。弱菜。。。几个月前时的我居然不会。。。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <climits>
#include <vector>
#include <queue>
#include <cstdlib>
#include <string>
#include <set>
#include <stack>
#define LL long long
#define pii pair<int,int>
#define INF 0x3f3f3f3f
using namespace std;
int ans;
void Fast(int n){
while(n){
if(n&) ans++;
n >>= ;
if(n) ans += ;
}
}
int main() {
int n,m;
scanf("%d",&n);
while(n--){
scanf("%d",&m);
ans = ;
Fast(m);
printf("%d\n",ans?ans-:ans);
}
return ;
}