Problem Description

Therearex frogs and y chicken in a garden. Kim found there are n heads and m legs in the garden. Please tell Kim how many frogs and chicken are there. (A frog has 4 legs, and a chicken has 2 legs.)

FZU 2272 Frog 第八届福建省赛 (鸡兔同笼水题)-LMLPHP Input

First line contains an integer T (1 ≤ T ≤ 10), represents there are T test cases.

For each test case: Two number n and m.

1<=n, m <=100000. The data is legal.

FZU 2272 Frog 第八届福建省赛 (鸡兔同笼水题)-LMLPHP Output

For each test case, output two numbers A and B – the number of frog and the number of chicken.

FZU 2272 Frog 第八届福建省赛 (鸡兔同笼水题)-LMLPHP Sample Input

2
2 6
2 4

FZU 2272 Frog 第八届福建省赛 (鸡兔同笼水题)-LMLPHP Sample Output

1 1
0 2
 
 #include<cstdio>
#include<iostream>
using namespace std; int main()
{
int T;
int n,m,a,b;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
a=(m-*n)/;
b=n-a;
printf("%d %d\n",a,b);
}
return ;
}
05-11 04:49
查看更多