圆的面积
Time Limit: 1000 ms Memory Limit: 32768 KiB
Problem Description
Give you the radius of a circle,caculate its area,PI=3.141592653。
Input
The first line of the input is a positive integer N,then follows N lines,each line is a real number represent the radius of the circle.
Output
Output contains N lines,for each line of the input you should output one line, Case K: S,and K(count from 1)represents the number of the circle and S is the area.Keep two digits after the decimal point.
Sample Input
3
1
2
3
Sample Output
Case 1: 3.14
Case 2: 12.57
Case 3: 28.27
注意圆周率的值。
import java.util.*;
public class Main
{
static public void main(String[] args)
{
Scanner cin = new Scanner(System.in);
int t,n;
node a = new node();
t = 0;
n = cin.nextInt();
while(++t<=n)
{
a.a = cin.nextDouble();
System.out.printf("Case %d: ",t);
System.out.printf("%.2f\n",a.GetSize());
}
cin.close();
}
}
class node
{
public double PI = 3.141592653;
double a;
double GetSize()
{
return a*a*PI;
}
}