Power Strings

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 50036 Accepted: 20858

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

 
KMP找不可重叠的最小循环节
 //2017-08-10
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm> using namespace std; const int N = ;
char str[N];
int nex[N]; void getNext(int n)
{
nex[] = -;
for(int i = , fail = -; i < n;)
{
if(fail==-||str[i]==str[fail])
{
i++, fail++;
nex[i] = fail;
}else fail = nex[fail];
}
} int main()
{
while(scanf("%s", str)!=EOF)
{
if(str[] == '.')break;
int n = strlen(str);
getNext(n);
int ans = n-nex[n];
if(n%ans == )
printf("%d\n", n/ans);
else printf("1\n");
} return ;
}
05-11 16:23
查看更多