This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (,) are the exponents and coefficients, respectively. It is given that 1,0.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

分析: 多项式加法,水题~
 /**
 * Copyright(c)
 * All rights reserved.
 * Author : Mered1th
 * Date : 2019-02-23-20.32.18
 * Description : A1002
 */
 #include<cstdio>
 #include<cstring>
 #include<iostream>
 #include<cmath>
 #include<algorithm>
 #include<string>
 #include<unordered_set>
 #include<map>
 #include<vector>
 #include<set>
 using namespace std;
 ;
 };
 int main(){
 #ifdef ONLINE_JUDGE
 #else
     freopen("1.txt", "r", stdin);
 #endif
     ;
     double a;
     scanf("%d",&k);
     ;i<k;i++){
         scanf("%d%lf",&n,&a);
         p[n]+=a;
     }
     scanf("%d",&k);
     ;i<k;i++){
         scanf("%d%lf",&n,&a);
         p[n]+=a;
     }
     ;i<maxn;i++){
         ){
             num++;
         }
     }
     printf("%d",num);
     ;i>=;i--){
         ){
             printf(" %d %.1f",i,p[i]);
         }
     }
     ;
 }
05-07 15:22
查看更多