1007 Maximum Subsequence Sum (25 分)
Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
分析:这里用最大连续子序列和的联机算法(复杂度O(n)):只进行一次遍历,若当前子序列和小于0则丢弃该序列,若比最大和大则记录此值为最大和。此题在此算法基础上增加了记录序列收尾元素的操作。
代码:
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
int main() {
int maxSum = -0x3fffffff;
int N;
cin >> N;
vector<int> v(N);
for (int i = 0; i < N; i++) {
cin >> v[i];
}
int tempSum = 0;
int tempIndex = 0;
int leftIndex = 0, rightIndex = N - 1;
for (int i = 0; i < N; i++) {
tempSum += v[i];
if (tempSum < 0) {
tempSum = 0;
tempIndex = i + 1;
}else if (tempSum > maxSum) {
maxSum = tempSum;
leftIndex = tempIndex;
rightIndex = i;
}
}
if (maxSum < 0) {
maxSum = 0;
}
cout << maxSum << ' ' << v[leftIndex] << ' ' << v[rightIndex] << endl;
return 0;
}