问题描述
以下哪些声明符合Java的命名约定?
Which of the following declarations conforms to Java's naming conventions?
private boolean writerIsEnabled;
// with methods like
public boolean getWriterIsEnabled()
public void setWriterIsEnabled()
OR
private boolean writerEnabled;
// with methods like
public boolean getWriterEnabled()
public void setWriterEnabled()
我个人觉得第一个名字writerIsEnabled更具可读性,特别是当你在if语句中使用它时 -
I personally find the first name "writerIsEnabled" to be more readable, especially when you use it in an if statement like this -
if(writerIsEnabled)
{
//...
}
推荐答案
据我所知,就是这样:
private boolean writerEnabled;
// with methods like
public boolean isWriterEnabled();
public void setWriterEnabled(boolean enabled);
当类型为 boolean
或 Boolean ,区别在于Getter以开头是
而不是 get
。
Either when the type is boolean
or Boolean
, the difference is that the Getter starts with is
instead of get
.
我个人更喜欢 isWriterEnabled
方法。例如,JSF等技术在访问属性时尊重该标准。 EL表达式通过
和获取
进行确认。
Personally I prefer the isWriterEnabled
approach. Technologies like, for example, JSF respect that standard when accessing properties. The EL expressions are acknowledged with is
and get
.
这篇关于布尔变量名的Java命名约定:writerEnabled vs writerIsEnabled的文章就介绍到这了,希望我们推荐的答案对大家有所帮助,也希望大家多多支持!