我试图查看C#编码标准以使我的代码更加美观和标准,并且我有一个问题:根据C#编码标准,函数(不是空方法)应该以“Get”开头吗?例如:“GetSongOrder()
”,“GetNextLine()
”等?
谢谢。
最佳答案
有两种情况:
如果例程可以非常快速地“获取”值,而又不会在代码中引起副作用,那么我建议使用属性 getter ,并省略“获取”名称:
public SongOrder SongOrder
{
get { return this.songOrder; } // ie: an enum
}
但是,如果需要处理,则使用名称为“Get ...”的方法是合适的。这表明调用此方法可能会有副作用,例如额外的处理或某些状态的更改:
public string GetNextLine()
{
string line = this.stream.ReadLine(); // This may cause a longer running operation, especially if it's using Disk IO/etc
// do other work?
return line;
}