Given three integers A, B and C in [−263,263], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
思路
  • a,b,c的范围就知道就算使用long long也是要溢出的,这里我尝试取巧地使用了long doubledouble在我的codeblock上是8字节,而long double是12字节,不知道OJ上的是怎么样的,试着用一下还过了…
代码
#include<bits/stdc++.h>
using namespace std;

int main()
{
    int n;
    long double  a,b,c;
    cin >> n;
    for(int i=1;i<=n;i++)
    {
        cin >> a >> b >> c;
        if(a + b >  c)
            cout << "Case #" << i <<": true" << endl;
        else
            cout << "Case #" << i <<": false" << endl;
    }
    return 0;
}
引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805406352654336

01-19 12:53
查看更多