Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<stack>
#include<math.h>
using namespace std;
int main()
{
    int a,b;
    cin>>a>>b;
    int sum=a+b;
    stack<int> s;
    if (sum==0)
    {
        cout<<0;
    }
    else
    {
    if (sum<0)
    {
        cout<<"-";
        sum=-sum;
    }
    while(sum>0)
    {
        int temp=sum%10;
        s.push(temp);
        sum/=10;
    }
    int k=0;
    int length=s.size();
        int point=length%3;
    while(!s.empty())
    {
        k++;
        cout<<s.top();
        s.pop();
        if ((abs(k-point))%3==0&&k!=length)
        {
            cout<<",";
        }
    }
    }
    cout<<endl;

    return 0;
}
01-07 01:49
查看更多