Closed. This question is opinion-based。它当前不接受答案。
想改善这个问题吗?更新问题,以便editing this post用事实和引用来回答。
2年前关闭。
这被认为是不好的做法吗?
具体来说,如果我将名称“ average”同时用作方法“ average”中的两个局部变量,可以吗?
想改善这个问题吗?更新问题,以便editing this post用事实和引用来回答。
2年前关闭。
这被认为是不好的做法吗?
具体来说,如果我将名称“ average”同时用作方法“ average”中的两个局部变量,可以吗?
public static double average(double[] arr) {
double average = 0.0;
for (int = 0; i < arr.length; i++) {
average += arr[i];
}
average /= arr.length;
return average;
}
最佳答案
该变量不代表average
,而是代表sum
。您应该这样命名。
public static double average(double[] arr) {
double sum = 0.0;
for (int = 0; i < arr.length; i++) {
sum += arr[i];
}
return sum / arr.length;
}