This question already has answers here:
Error after upgrading to xcode 4.6 and iOS 6.1 “used as the name of the previous parameter rather than as part of the selector”
(3个答案)
7年前关闭。
我从Xcode 4.6得到以下警告。
我知道我可以禁用此警告,但是我想修复它。
我有109条这样的警告,因此我显然写得不好。
这是我的几种方法。
那么,编写这些方法的正确方法是什么?
像
实际上,您应该做的是为先前的参数命名,例如
然后像
(3个答案)
7年前关闭。
我从Xcode 4.6得到以下警告。
.. used as the name of the previous parameter rather than as part of the selector
我知道我可以禁用此警告,但是我想修复它。
我有109条这样的警告,因此我显然写得不好。
这是我的几种方法。
+(NSString*)addFormatPrice:(double)dblPrice:(BOOL)booRemoveCurSymbol;
-(void)showHelpChoices:(UIView *)vw:(id)dg;
那么,编写这些方法的正确方法是什么?
最佳答案
您的第一种方法是声明选择器+addFormatPrice::
。有空格,看起来像
+ (NSString *)addFormatPrice:(double)dblPrice :(BOOL)booRemoveCurSymbol;
像
[NSString addFormatPrice:0.3 :YES]
一样调用。实际上,您应该做的是为先前的参数命名,例如
+ (NSString *)addFormatPrice:(double)dblPrice removeCurSymbol:(BOOL)booRemoveCurSymbol;
然后像
[NSString addFormatPrice:0.3 removeCurSymbol:YES]
那样调用它。关于iphone - Xcode 4.6,用作上一个参数的名称,而不用作选择器的一部分,我们在Stack Overflow上找到一个类似的问题:https://stackoverflow.com/questions/14660091/
10-10 06:24