Types of Background Process

  1. login item

  2. xpc service

  3. daemon/agent (也可以叫 mach service)

  4. startup item

login item

login items 是 OS X 对需要开机运行的APP推荐的启动方式,当用户登录之后自动调起程序,配置 login item 有两种方式:

  1) LSSharedFileListInsertItemURL() 或者 系统偏好设置->用户和群组>登录项

    通过这种方式,login item 会被保存在路径: ~/Library/Preferences/com.apple.loginitems.plist

  2) Service Management Framework

    方式1不可以在 sand box 中使用,Service Management Framework 可以,但是他要求 app 有一个 helper 程序。

    helper 程序存放在 app 的 Contents/Library/LoginItems 目录下,app 的主程序通过在运行时调用 SMLoginItemSetEnabled() 函数来设置 helper 程序为自启动程序,helper 程序在自启动后则可以调起其他程序。

    另外,方式2只适用于 app 被保存在 /Applications/ 路径下的情形。

    

xpc service

XPC 是 OS X 下的一种 IPC (进程间通信) 技术, 它实现了权限隔离, 使得 App Sandbox 更加完备。

使用 XPC,可以将 app 拆分为『主进程+XPC服务』的模式,这哥模式的好处是可以实现错误隔离和权限隔离。

xpc service 通过 NSXPCListener 对象来监听从主进程传入的请求,与主进程之间的通信通常是异步的。

xpc service 的生命周期都由 XPC 来进行控制,当 xpc service 在接收消息时 crash 了,其对应的 connection 依然直有效,但是这个未被处理的消息需要主进程重新发送请求。

OS X background process-LMLPHP

daemon/agent

daemon 和 agent 都是由 launchd 进程负责启动的后台作业,launchd 是 OS X 系统用户态的第一个进程。

根据安装路径,可以细分为:

  1. ~/Library/LaunchAgents: 每个用户私有的agent

  2. /Library/LaunchAgents: 所有用户共有的agent

  3. /Library/LaunchDaemons: 所有用户共有的 daemon,具有root权限

  4. /System/Library/LaunchAgents: 系统配置的 agent

  5. /System/Library/LaunchDaemons: 系统配置的 daemon

daemon/agent 通过 plist 文件(property list)进行编程并存入上文所描述的路径中。

如何编写和配置 plist,可以参考:

  http://www.launchd.info/

  https://developer.apple.com/legacy/library/documentation/Darwin/Reference/ManPages/man5/launchd.plist.5.html

注:通过下图可知,当 daemon 调起有 UI 程序时,会以 agent 的权限调起 UI 程序。

OS X background process-LMLPHPOS X background process-LMLPHP

startup item

根据官方文档,这个方式将在以后被废弃,有兴趣可以去看官方文档。另外,想找这方面的实例可以去参考 cisco 的 anyconnect,它使用的就是 startup item 来配置程序的自启动。

https://developer.apple.com/library/content/documentation/MacOSX/Conceptual/BPSystemStartup/Chapters/StartupItems.html

其他参考:

http://www.codesec.net/view/219693.html

https://developer.apple.com/library/content/documentation/MacOSX/Conceptual/BPSystemStartup/Chapters/Introduction.html

https://developer.apple.com/library/content/technotes/tn2083/_index.html

https://objccn.io/issue-14-4/

05-11 17:30