守护雅典娜

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 740    Accepted Submission(s): 250

Problem Description
许多塔防游戏都是以经典的“守护雅典娜”为原型的。玩家需要建立各种防御工具来阻止怪物接近我们的女神——雅典娜。

这里,我们可以建造的防御工具只有标准圆形状的防御墙,建立在雅典娜与怪物出生点之间的防御墙数目越多,胜利的希望就越大。这里,将问题简化到一个二维坐标系里,并且假设雅典娜的坐标为原点(0, 0),怪物出生点的坐标为(X, Y)。有N个给定圆心坐标与半径的防御墙可以供玩家选择建立,但要保证所有的圆都不发生相切或相交的情况。注意这些雅典娜位置与怪物出生点位置也不能在墙壁的边缘,即表示防御墙的圆上。点的面积与墙的厚度都很小,可以忽略不计。

记住,在游戏开始之后,怪物可以沿着任何轨迹,选择突破最少的圆形防御墙来到雅典娜的身边,而一个防御墙一旦被突破,它就会失去保护作用。所以,你的方案必须足够优秀。为了守护女神,快去找出最优的建设方案吧!

 
Input
输入第一行为T,表示有T组测试数据。
每组数据以三个整数N,X,Y开始,接下去的N行每行包括三个整数Xi,Yi,Ri,表示一个可以选择的圆心为(Xi, Yi)半径为Ri的防御墙。

[Technical Specification]

1. 1 <= T <= 100
2. 1 <= N <= 1000
3. 1 <= Ri <= 10 000
4. -10 000 <= X, Y, Xi, Yi <= 10 000,坐标不会相同

 
Output
对每组数据,先输出为第几组数据,然后输出能够间隔在雅典娜与怪物出生点之间最多的防御墙数目。
 
Sample Input
3
1 5 5
1 0 2
1 5 5
1 0 9
3 5 5
1 0 2
4 5 2
2 0 6
 
Sample Output
Case 1: 1
Case 2: 0
Case 3: 2
 
Source
 
Recommend
liuyiding
 

Statistic | Submit | Discuss | Note

析:首先先找出来两种圆,一种是只包含怪物的,另一种是只包含雅典娜的,因为都包含或者都不包含的没什么意义,排序,从小到大按半径,然后分别进行dp,最后肯定是包含的选出最多一个,然后再进行合并。

代码如下:

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <cstdio>
#include <string>
#include <cstdlib>
#include <cmath>
#include <iostream>
#include <cstring>
#include <set>
#include <queue>
#include <algorithm>
#include <vector>
#include <map>
#include <cctype>
#include <cmath>
#include <stack>
#include <sstream>
#include <list>
#include <assert.h>
#include <bitset>
#define debug() puts("++++");
#define gcd(a, b) __gcd(a, b)
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define fi first
#define se second
#define pb push_back
#define sqr(x) ((x)*(x))
#define ms(a,b) memset(a, b, sizeof a)
#define sz size()
#define pu push_up
#define pd push_down
#define cl clear()
#define all 1,n,1
#define FOR(i,x,n) for(int i = (x); i < (n); ++i)
#define freopenr freopen("in.txt", "r", stdin)
#define freopenw freopen("out.txt", "w", stdout)
using namespace std; typedef long long LL;
typedef unsigned long long ULL;
typedef pair<int, int> P;
const int INF = 0x3f3f3f3f;
const double inf = 1e20;
const double PI = acos(-1.0);
const double eps = 1e-8;
const int maxn = 1000 + 10;
const int maxm = 1e5 + 10;
const int mod = 50007;
const int dr[] = {-1, 0, 1, 0};
const int dc[] = {0, -1, 0, 1};
const char *de[] = {"0000", "0001", "0010", "0011", "0100", "0101", "0110", "0111", "1000", "1001", "1010", "1011", "1100", "1101", "1110", "1111"};
int n, m;
const int mon[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
const int monn[] = {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
inline bool is_in(int r, int c) {
return r >= 0 && r < n && c >= 0 && c < m;
} struct Point{
int x, y;
Point() { }
Point(int xx, int yy) : x(xx), y(yy) { }
friend Point operator - (const Point &lhs, const Point &rhs){
return Point(lhs.x - rhs.x, lhs.y - rhs.y);
}
}; int dist(Point p){
return sqr(p.x) + sqr(p.y);
} struct Circle{
Point c;
int r;
bool operator < (const Circle &c) const{
return r < c.r;
}
};
Circle c[maxn];
Point athene, monster; int isintersection(const Point &p, const Circle &c){
int d = dist(p - c.c);
return d - sqr(c.r);
} bool not_intersection(const Circle &c1, const Circle &c2){
int d = dist(c1.c - c2.c);
return d > sqr(c1.r + c2.r);
} bool isinclude(const Circle &c1, const Circle &c2){
int d = dist(c1.c - c2.c);
return sqr(c1.r - c2.r) > d;
} vector<Circle> aths, mos;
int f[maxn], g[maxn]; int main(){
monster.x = monster.y = 0;
int T; cin >> T;
for(int kase = 1; kase <= T; ++kase){
mos.cl; aths.cl;
scanf("%d %d %d", &n, &athene.x, &athene.y);
for(int i = 0; i < n; ++i){
scanf("%d %d %d", &c[i].c.x, &c[i].c.y, &c[i].r);
int id1 = isintersection(athene, c[i]);
int id2 = isintersection(monster, c[i]);
if(id1 < 0 && id2 > 0) aths.push_back(c[i]);
else if(id1 > 0 && id2 < 0) mos.push_back(c[i]);
}
sort(aths.begin(), aths.end());
sort(mos.begin(), mos.end());
int ans = 0;
for(int i = 0; i < aths.sz; ++i){
f[i] = 1;
for(int j = 0; j < i; ++j)
if(isinclude(aths[i], aths[j])) f[i] = max(f[i], f[j] + 1);
ans = max(ans, f[i]);
}
for(int i = 0; i < mos.sz; ++i){
g[i] = 1;
for(int j = 0; j < i; ++j)
if(isinclude(mos[i], mos[j])) g[i] = max(g[i], g[j] + 1);
ans = max(ans, g[i]);
}
for(int i = 0; i < aths.sz; ++i)
for(int j = 0; j < mos.sz; ++j)
if(not_intersection(aths[i], mos[j])) ans = max(ans, f[i] + g[j]);
printf("Case %d: %d\n", kase, ans);
}
return 0;
}

  

05-11 09:34