题目是这样的:

描述

hihocoder:#1082 : 然而沼跃鱼早就看穿了一切(用string)-LMLPHP

fjxmlhx每天都在被沼跃鱼刷屏,因此他急切的找到了你希望你写一个程序屏蔽所有句子中的沼跃鱼(“marshtomp”,不区分大小写)。为了使句子不缺少成分,统一换成 “fjxmlhx” 。

输入

输入包括多行。

每行是一个字符串,长度不超过200。

一行的末尾与下一行的开头没有关系。

输出

输出包含多行,为输入按照描述中变换的结果。

样例输入

The Marshtomp has seen it all before.
marshTomp is beaten by fjxmlhx!
AmarshtompB

样例输出

The fjxmlhx has seen it all before.
fjxmlhx is beaten by fjxmlhx!
AfjxmlhxB

这里工作应该是很明确的,查找和替换,string类提供了很方便的函数去查找和替换,由于大小写的不同可以先用复制一个副本,然后统一大小写,然后查找再替换。

代码如下:

#include<cstdio>
#include<string>
#include<iostream>
#include<cctype>
using namespace std;
int main()
{
string a,b="marshtomp";
while(getline(cin,a)){
string a1=a;
for(int i=0;i<a.size();i++)
a[i]=tolower(a[i]);
int x;
while((x=a.find(b))>=0){ //这里因为一行可能不止一个,所以用循环,刚开始就因为这个WA了可久
a1.replace(x,9,"fjxmlhx");
a.replace(x,9,"fjxmlhx");
}
cout<<a1<<endl;
}
return 0;
}
05-11 10:54